Wednesday, July 02, 2008

Back on Xournal

UPDATE:
Looks like too many people have the maemo extras-devel repository installed.
They should not. Or at least, they should know what the extras-devel repo is.
The maemo extras-devel repository is intended as a tool for the developer to test out its code before promoting it to the real maemo Extras repository (the one that's pre-configured in your tablet when you buy it, disable).

Today I've uploaded an alpha version of Xournal (packaged for diablo) on the maemo extras-devel repository. Thus, those people got the notification of an update available and went straight to the Application Manager in order to update.

I see here two mistakes:

1) they should have not installed the -devel repository (unless they knew what they were doing)
2) the Application Manager should TELL from WHERE the package is coming from

However, the next release of Xournal HAS NOT YET been released.
And I strongly suggest, whoever has the maemo extras-devel repo installed, to NOT update to the Diablo version yet.

Check out this ITt forum thread for more info.
My post #198 on that thread explain how to solve the issue.

Thank you.

Original post:

Today I noticed that Xournal has been selected as "The Pearl" in the Maemo Downloads section.

Right on time, I would say as this morning I woke up and decided that it's time to upgrade my Maemo SDK to Diablo and re-package Xournal in order to make it appear in the Diablo extras repository.

So, thank you Maemo team for choosing Xournal as the current pearl!

Stay tuned, it shouldn't take too much time.

4 comments:

option8 said...

just an FYI, i installed Diablo last night and Xournal 0.4.2.1 today - xournal doesn't launch :(

hopefully it's a small thing, and you can get it updated for diablo without much trouble.

thanks for this port!

Jane said...

I really need some help! I've been using xournal 0.4.1 for months on my nokia n810 and I just love it! I use it for all my note taking and such! But when looking though the application manager it said there was an update for it. So I thought YAY! even better xournal! But i somehow managed to uninstall the old version... and when I tried to install the new version from the maemo site it says:
"Unable to install. Software contains updates to packages installed from a different source and is likely to harm the system. Contact software author"

And now I can't find a way to install the old version I had so can't even put that back on....

I have no idea what I'm doing and could really use some step by step instructions on what I'm doing wrong! I can't do without this programme!! I can't read any of my files!!

So please please please some one help me!!

kfx said...

Are you still going to update this for Diablo?

Anidel said...

The chinook version that you can find on the Maemo.org download pages, works fine in Diablo.
I am planning to start working on porting it to Fremantle with a few new features.
I'll to make this new version installs on Chinook, Diablo and Fremantle.

Thanks for asking...